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Introduction

Installation

Power Xpert Software's Waveform Viewer is a powerful tool for analyzing power
quality. The tool captures and displays AC waveforms in a color-coded graphical format
making viewing and analysis fast and easy.

Waveform Viewer gives you the tools to:
¢ View and analyze waveforms from events in a web browser.

e View trends for historical data, including data captured by Powernet devices or up-
loaded from Power Xpert Meters.

¢ Use zoom, pan, and scroll controls to traverse and magnify complex waveforms.
e Spot trends.

¢ Monitor voltage disturbances, voltage variances, etc.

Waveform Viewer is shipped on the Power Xpert Software CD. There are two ways
to install the Waveform Viewer:

1. If you purchased Waveform Viewer at the same time as Server Core software, it
will be automatically installed along with the Server Core. Refer to the Server Core
Administration Guide for installation details.

2. Ifyou purchased Waveform Viewer after you've installed the Server Core software.
When you receive a new license key you can install the Waveform Viewer by
modifying the existing Server Core software. Refer to the Server Core Administration
Guide for installation details and follow the optional step to modify an existing in-
stallation.







Using the Waveform Viewer

Using the Waveform Viewer in the Power Xpert Web Application

Within the Power Xpert Web Application you can use the Waveform Viewer to view
waveforms from events. To launch the Waveform Viewer from the Alarms/Events
page, either:

¢ Click the Alarms/Events bar on the left side of the screen

e Select Waveform Viewer by using the Navigation menu (on the toolbar).

Alarms/Events Tasks
Alams and Ewents Search
Alamms and Events Freferences... %
Zomgelpais S Ao Betiesh Alarma Events List
Alarms/Events
—=
06 Mar 07 14:05:52.521 ITIC “n L8 Sag | Fower Hpert Meter D3AG/Z007 02 0506113 P (] L1 | || |Highest ]
06 Mar 07 13:10:40.502 Sub-Cysle Disturbl Pomer Jpert Meter DHG/2007 01:10:40.502 PM = [0 | [ |Hignest
06 Mar 07 13:10:40.620 ITIC “en L8 Sag | Fower Hpert Meter D3GZ007 01, 08:24.020 Pt = [0 | [ |Hgnest
05 Mar 07 13:09:24.013 Sub-Cysle Disturtl Fomer Jpert Mster DHG/Z007 01:09:24.013 PM =] [0 | O |Hanest
06 var 07 13:07:32.475 ITIC on L3 Sag | Fower Xpert hieter 03ABZ007 01 0732475 Pht [ 0| O |Haness |
0 Mar 07 12.03:08.810 Sub-Cysle Disturtl Fower Mpert Meter DHUG/Z007 01 0308210 FM =] O | O [Hewst |
06 Mar 07 11:43:04.0400 ITIC ven L8 Sag | Power Hpert hster OE007 11:43:04.040 At ] O | OO [Hones |
06 Mar ‘07 1148:04.040 ITIC Yon L8 Sag | Fower Hpert Meter DHGZ007 114802124 At =] O | O [Hewest |
0 Mar 07 11:41:21.826 ITIC van L8 Sag | Power Jpert Mater DHGZ007 11:41:19.612 At ] 0| [ |Hgnest |
06 Mar ‘07 11:41:14.282 Sub-Cyele Disturbl Fower Ypert Meter DHGZ007 11:41:14.287 At =] O | O [Hewest |
0 Mar 07 11:41:14.285 ITIC Yen L9 Sag | Power Jpert Mater DHOGZ007 11:41:11.945 At =] [0 | [ |Hgnest
06 Mar ‘07 114050530 ITIC Yon L8 Sag | Fower Hpert Meter DHG/Z007 114067 088 At = [ | [ |Honest
06 Mar 07 11:40:43.726 ITIC bn L2 Sag | Power Jpert Meter DHGZ007 11:40:42.435 At =] [0 | [ |Highest
06 Mar ‘07 113740617 Sub-Cyele Disturtl Fower Xpert Meter DHGZ007 113740517 At = [0 | [ |Honest
05 Mer 07 11:37:40.571 ITIC ven L8 Sag | Fower Jpert Mster DHGZ007 11:37:19.121 A =] | O |Hgnest &l
06 er ‘07 11:35:31 284 Sub-Cyele Disturbl Fomer Ypert hster O3ABZ007 11:3551 254 At ] 11T [Highest i

An example of the Events page from Power Xpert Software, showing the detail
icons

To see if a waveform is available for a particular event, click the detail icon for that
event.

Note
It can take 10 minutes for a waveform to be available after an event occurs.

If an event comes from a device via PowerNet, a waveform icon will be on the bottom
right of the screen. Click the icon to launch the Waveform Viewer's Waveform Viewer.




Quick Tour of the Waveform Viewer

Alarm and Event Details

[Cescaiptions 08 Mar'07 11:37:40.521 ITIC Ven L& Sag
Device: Powsr Xpert Meter Categery: Alamm Time Logged 03762007 11:37:19.121 AM
Aftribute: state Active Time Ack
Fricrity: Highast Time Cleared:  03/08/2007 11:37:40.521 AM
Time Closed:
ECIT) T =)
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000 030607 11:37:40.621
001 12 5ag
001 el 162458
003 ITIC \bage:0. 152466 \/
004 e 234480 %
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00 e, 400
Hotes New Evert
=| |uameszon? 113740521 A
Severty | Eritical Qlevel = -8)
Conditien Present | False

Hotes
=| |oamezz007 11:37 40 521 A

| Ewent is no longer active

=l [wave

Severty | Eritical Qlevel = -8)

Condiion Prasent Faiss

007 | Aaded Waveform 2to evert

Notes [Waveforn Associated uith event
eform [ wd
030672007 113740 521 24 v

-

The waveform icon on the Details Page

Quick Tour of the Waveform Viewer

Refer to the following illustration and legend for a description of the various controls.
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Attribute selector. This is the set of available attributes in waveform data. Each
channel selected appears in the plots. Select the check box to plot the waveform
for that attribute. Click next to the label (as shown in preceding figure) to select
a single attribute in the plots. This highlights the associated line in the plots and
activates one of the harmonics controls for the applicable harmonics.
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Tabs

Tabs

The Device Harmonics viewer button. If an attribute is currently selected from
an 1Q Analyzer or MPCV Relay, this button becomes active. Click the button to
view the harmonics data for the selected attribute. See the section on the Har-
monics Viewers for more information.

The Signal Harmonics button. For waveform data originating from most devices,
if an attribute is selected this button becomes active. Click the button to view
the harmonics data for the selected attribute. See the section on the Harmonics
Viewers for more information.

The cursor selector window. Selecting an attribute places a color-coded cursor
in the plots. You can click-and-drag the cursor to view the values along the
timeline.

The toolbar. See the Toolbar section for a description of each tool.

The Current plot.

The Voltage plot.

The digital I/O plot. If the device has digital inputs, their states will be plotted at

against time in this graph. (If you don't see this graph, extend the window
downward.)

The Waveform Viewer has three tabs: Plot (which was shown in the previous section),
Data, and Header. The Data tab provides detailed information about the waveform data,
including the event number and information about each attribute. Clicking an attribute
loads the right pane of the window with that attribute’s detailed information. Expand
the Points item to see the individual data points that make up the waveform.

e
File  Help
Plat Data | Header

Object Type Harmaonics [Callection]
Ewvent3289 waveform
WEGALR [77) Analog Sig...
WAG [WA) Analog Sig...
18, [14] Analog Sig...
WBG [VE] Analog Sig...
IE [IB] Analog Sig...
WCG VC) Analog Sig...
IC(IC) Analog Sig...
WHG VM) Analog Sig...
1M [IM] Analog Sig...
WVAGALL [77) Analog Sig...
1G (1G] Analog Sig... =]
YBGAL (7] Analog Sig...
D1z Input One [77] Digital Signal
D12 Input Two [77) Digital Signal
D13 Input Three [77] Digital Signal
Dl4:Input Four [77) Digital Signal
D5 nput Five (77 Digital Signal
DB Input Siw [77] Digital Signal
DIF:Input Seven [77] Digital Signal
D18 Input Eight [77] Digital Signal

The Data Tab
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Harmonics Viewers

The Header tab displays the file header information for the waveform file currently
loaded. Files from Powernet (.osw files) don’t have headers.

WAy E o EwWe e owE T E M e e TRl 1 6V D D BRI MO S A
File  Help

Plat | Data | Header

EventlD=3752

Description:! 16 Apr '08 23:01:52.317 -0400 Out of Limits [avg Caution High
‘whed, 16 Apr 2008 23:01:52 -0400

type: [CD ateTime] element: [eProsyE lement_lnvalid] value: [wed, 16 Apr 2008 23:01:52 -0400] unit: []
tupe: [ETriggerState] element: [eProxyElement_lreyalid] value: [2TrgState_CautionHigh] unit: []
type: [float32_t] element: [ePray_lavg] value: [14.5044] unit: []

type: [float32_t] element: [ePray_00LAve] walue: [9.34292] unit: []

type: [float32_t] element: [ePray_00LStdDes] value: [0.778577] unit: []

type: [uink32_t] element: [ePray_InLimitCount] value: [2296235] unit: []

tupe: [uink32_t] element: [eFra_TotalCount] value: [2723551] unit; []

type: [float32_t] element: [ePray_|nLimitPercentage] value: [84.3103] unit: [%]
type: [float32_t] element: [ePray_Van] value: [123.36] unit: []

type: [float32_t] element: [ePray_Wbn] walue: [123.203] unit: []

type: [float32_t] element: [ePray_Veon] walue: [123.559] unit: [

twpe: [float32_t] element: [ePray_Winawg) value: [123.374] unit: [W]

type: [float32_t] element: [ePray_Vab] value: [213.64] unit: []

tpe: [float32_t] element: [ePray_Whe] walue: [213.447] unit: []

type: [float32_t] element: [ePray_Veoa] value: [213.951] unit: [¥]

type: [float32_t] element: [ePray_Wilavg] value: [213.677] unit: [+¥]

tupe: [float32_t] element: [aPray_la] walue: [7.32544] unit: [4]

twpe: [float32_t] element: [ePray_|b] walue: [28.2282] unit: [4]

tpe: [float32_t] element: [ePray_lc] walue: [7.95966] unit: [4]

type: [float32_t] element: [ePray_lavg] value: [14.5044] unit: [4]

twpe: [float32_t] element: [ePray_In] walue: [22.197 4] unit: [4]

tupe: [flaat32_t] element: [aPry_|g] walue: [0] urit: [4]

type: [uink32_t] element: [ePray_Lastw aveformld] value: [4635] unit: []

type: [int32_t] element: [ePray_'wWaveformTriggerOffset] walue: [0] unit: []

The Header Tab

Harmonics Viewers

Waveforms from the 1Q Analyzer or MPCV Relay contain attributes that provide device
harmonics information and attributes from other devices may provide signal harmonics
information. In both cases, you must first select the attribute by clicking its label before

the appropriate button will become active.

12 (C)

IN ()

VAN (8) %
WEN (B)

Selecting an Attribute

Clicking the Harmonics button launches the Harmoncs Viewer, which provides both a
bar chart and a table of datapoints. The Export button on the toolbar writes a file of the

current plot in one of several graphics formats or the Frequency and Amplitude data
to a tab delimited ASCII file with a .dat extension.
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Toolbar

Toolbar

[#] Flianioies of b (A) J J Lz

Q& BiE

Amplitude [V
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£0000.00
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2000000
0.00 —= = T [T e T e [
15 20 % 30 5
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40 45 50
Frequency [f=E0Hz)

Amplituice Percentage Phaze

3014057 100% 063 Degrees

92659 98Y 3074 23% 0785 Degrees

92652 202 3073.972% 0783 Degrees

92676 243 3074.77% 0783 Decrees b |
92661 396 3074.277% 0786 Degrees

Ga533Y 2174 224% 1571 Deorees

46 B15% 1.547% 0618 Degrees

Q2676 243V 3074.77% 0.785 Deorees !
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Ba534Y 2174 257% 1571 Degrees

B3535Y 2174.29% 1571 Deorees

o 0% Mahl Degrees

92650 486% 3074.911% 0.785 Deqrees

Device Harmonics

The Signal Harmonics button launches the Harmonics Viewer and displays signal
harmonics data for the selected channel. The viewer controls are the same as for Device
Harmonics.

The toolbar provides controls for adjusting the plot access, zooming in on areas of in-
terest, exporting data, or printing plots. An abridged version of the toolbar exists in the
Harmonics viewers. Refer to the following for the function of each of the tools:

Tool Function

2
+

&

Resume...Click to restore zoom level to default.
Axes Scroll...Click the X or Y axis of the current or voltage plot and drag to scroll.

Axes Zoom:...Click the X or Y axis of the current or voltage plot and drag to in-
crease or decrease the resolution.

Zoom-Out...Click the tool to zoom out on both the current and voltage plots.
Zoom-In... Click the tool to zoom in on both the current and voltage plots.
Select...Click the voltage or current plot to zoom in on the selected point.

Zoom Box...Click and drag a selection box on either the current or voltage plots
to zoom in on that area.

Copy to Clipboard...Click to copy waveform data to the Windows clipboard. Use
the drop-down list next to the tool to select to copy either the plot picture or tab-
delimited attribute data.

Export...Click to export the plot as a graphics file (you can select the format) or,
if the .dat file extension is select, export the data as a tab-separated ASCII file.
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Working With Waveform Files

Tool Function
= Print...Print the selected plot.

Working With Waveform Files

The Waveform Viewer can load waveform files either in the industry standard Comtrade
format or the Powernet waveform format (.osw) files. You can load waveform files
from either your local computer’s file system (including mapped network resources)
or directly from the Power Xpert Software server. Files loaded from the Power Xpert
Software server are actually waveform data stored in the Power Xpert Software data-
base, and are either in .osw format if the waveform originated on a Powernet device
or Comtrade format if the waveform came from a PowerXpert meter.

The File menu provides access to the file load commands. To use the Open Waveform
from Server command, you'll need to know the web address of the Power Xpert
Server.

After loading a file from the server, you can save it to your file system via the File >
Save as command. The default file name is the event ID. You can only save the file in
its original format.
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